CRD 2.0 download page appears to be broken, can't figure out if it's my end or not.


lockedacclul
 Share

Recommended Posts

I've been trying to download the CRD 2.0 mod, but whenever I press "Agree and download" I'm greeted with a "this site can't be reached" error. I've tried downloading on both Chrome and Edge, same error for both browsers.

I'm able to download all other mods on the site, so I'm not sure what the problem is... I would appreciate it if other users could try reaching the download page so I know if it's on my end or not. Thanks!

Link to comment
Share on other sites

I just tried to re-download it and I was able to without issues. After I clicked "Agree and Continue" the download started in my browser, I wasn't redirected to a separate upload site or anything like some downloads do. I think it might be on your end, but unfortunately I don't really have a solution for you. Hope you get it figured out!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share